Quantcast

endoscopy

Help Support ValveReplacement.org:

Kathy McCain

Well-known member
Joined
Jan 10, 2008
Messages
1,087
Location
Texas
Hi everyone! Hope all has been well!

Has anyone here had an upper endoscopy recently? If so, did you take an antibiotic at anytime before during or after your procedure? Did you experience any problems?

I had this procedure six days ago. Even though the American Heart Assoc has stated it is no longer neccesary to take antibiotics I did take Amoxicillian the day before, day of, and the day after.

Thanks in advance for any information you can give.
 

Duffey

Me and Granbon
VR.org Supporter
Joined
Sep 29, 2004
Messages
5,247
Location
Far side of the moon
I didn't have an endoscopy, I underwent a colonoscopy, but I was told that they the same method of delivering the antibiotic is used for both. They piggy-backed an antibiotic to my IV solution. No problems from it.
 

Julian

Well-known member
Joined
Jun 21, 2011
Messages
581
Location
Southern California
I have not had an endoscopy but I know my surgeon's office has told me they want me to take antibiotics no matter what the American Heart Assoc says.
 

nngbwh

Proud member of Throwdown
VR.org Supporter
Joined
Nov 16, 2009
Messages
2,522
Location
Boston, MA
Its better to be safe than sorry. I guess its no harm taking antibiotics even if you don't need it.

Nice to see you back here again.
 

tprice54

Well-known member
Joined
Apr 23, 2006
Messages
763
Location
Clay, NY
I had one 6 months ago, did the piggyback IV antibiotics just before and after the procedure.......
 
Top